题目是这样子的

莫比乌斯函数,由德国数学家和天文学家莫比乌斯提出。梅滕斯(Mertens)首先使用μ(n)(miu(n))作为莫比乌斯函数的记号。(据说,高斯(Gauss)比莫比乌斯早三十年就曾考虑过这个函数)。
具体定义如下:
如果一个数包含平方因子,那么miu(n) = 0。例如:miu(4), miu(12), miu(18) = 0。
如果一个数不包含平方因子,并且有k个不同的质因子,那么miu(n) = (-1)^k。例如:miu(2), miu(3), miu(30) = -1,miu(1), miu(6), miu(10) = 1。
给出一个数n, 计算miu(n)。

Input
输入包括一个数n,(2 <= n <= 10^9)
Output
输出miu(n)。
Sample Input
5
Sample Output
-1

这题时间限制是1s,因此无法通过先建立质数表然后再查询的方法进行,因此需要直接分解质因数。

#include <iostream>
#include <math.h>
using namespace std;
typedef long long ll;
#define MAXN 10e9 + 10


ll miu(ll n)
{

    ll miu = 0;
    ll prime_js = 1;
    bool has_n2_factor = false;

    for(int i=2;i*i<=n;i++)
    {
        int cnt=0;
        if(has_n2_factor) break;
        if(n%i==0)
        {
            prime_js++;//质因子出现次数加1
            while(n%i==0)
            {
                n/=i;
                cnt++;//记录该质因子出现的次数
            }

            if(cnt>=2) has_n2_factor=true;
        }
    }

    if(has_n2_factor) miu = 0;
    else
    {
        miu = pow(-1,prime_js);
    }
    

    return miu;
}

int main()
{

    ll n;
    cin >> n;
    cout << miu(n) << endl;
    //system("pause");
}

你也可能喜欢

发表评论